Come risolvere: tipo di archivio non supportato in Ubuntu Linux

Problema:

I problemi con l'estrazione di file di archivio sono molto comuni in qualsiasi sistema Linux. Ci sono problemi con i file .cbr, i file RAR e poi ci sono i problemi comuni con gzip stdin non nel formato gzip. Ancora una volta, mi sono imbattuto in un problema simile con il file compresso in Ubuntu.

Stavo cercando di installare uno script Conky che avevo scaricato da devianART. Quando ho estratto per la prima volta il file gzipp scaricato, ne ho estratto un altro compresso senza estensione . Quindi, quando ho provato ad estrarlo in Nautilus, ha lanciato un errore sul mio volto che diceva: Tipo di archivio non supportato .

Ragionare:

Per trovare la fonte dell'errore, sono passato alla riga di comando e ho eseguito un comando "file" per controllare il tipo di file compresso. Mi ha detto che si trattava di un archivio tar POSIX. Sono rimasto sbalordito dal fatto che il gestore di archivi predefinito di Ubuntu non fosse in grado di estrarre un file tar archived. Ma poi mi ha fatto clic. Il file non aveva estensione .

Soluzione:

Una volta compreso che il problema era di nuovo semplice e stupido con estensione di file assente o errata, la soluzione era semplice. Ho appena rinominato il file da .tar e l'uomo ha funzionato come un incantesimo. In alternativa, puoi estrarlo nella riga di comando, dopo averlo rinominato, nel modo seguente:

 tar .tar 

Come ho detto, la maggior parte delle volte il problema riguarda il nome dell'estensione. Spero che questo aiuti a sbarazzarsi dell'errore di tipo Archive non supportato in Ubuntu e in altri sistemi Linux. Abbi cura della prossima volta.

Raccomandato

4 migliori strumenti gratuiti e open source per l'elaborazione di immagini RAW in Linux
2019
NVIDIA termina il supporto per i sistemi operativi a 32 bit
2019
I migliori editor di testo per Linux Command Line
2019