Come risolvere "Le informazioni di aggiornamento sono obsolete" in Ubuntu Linux

Vedendo un triangolo rosso nel pannello superiore in Ubuntu 14.04 che mostra il seguente errore?

Le informazioni di aggiornamento sono obsolete. Ciò può essere causato da problemi di rete o da un repository che non è più disponibile. Aggiorna manualmente selezionando "Mostra aggiornamenti" dal menu dell'indicatore e osservando eventuali repository non funzionanti.

Sembra qualcosa del genere:

Invece del triangolo rosso, c'è un punto esclamativo rosa perché sto usando uno dei migliori temi di icone di Ubuntu, Numix. Tornando all'errore, questo è un problema di aggiornamento comune che potresti vedere ogni tanto. Ora ti starai chiedendo che cosa sta causando questo errore di aggiornamento.

Motivo dell'errore 'aggiornamento informazioni obsolete'

La ragione è piuttosto esplicativa nella descrizione dell'errore stessa. Si legge "questo potrebbe essere causato da problemi di rete o da un repository che non è più disponibile". Quindi, o hai aggiornato il tuo sistema e alcuni repository o PPA non sono più supportati o stai affrontando un problema simile.

Sebbene l'errore si spieghi da sé, l'azione che suggerisce "Aggiorna manualmente selezionando" Mostra aggiornamenti "dal menu degli indicatori e osservando eventuali repository non funzionanti.", Non funziona correttamente. Se fai clic su Mostra aggiornamenti, tutto ciò che vedrai è che il sistema è già aggiornato.

Strano non è vero? Come scopriremo cosa sta fallendo dove e perché?

La correzione delle informazioni di aggiornamento non è aggiornata

La 'soluzione' discussa qui funzionerà con le versioni di Ubuntu sia Ubuntu 14.04, 12.04 o 16.04. Tutto quello che devi fare è aprire un terminale (Ctrl + Alt + T) e utilizzare il seguente comando:

sudo apt-get update 

Aspetta che il comando finisca e guarda il risultato. Suggerimento rapido da aggiungere qui, è possibile aggiungere notifiche nel terminale in modo da ricevere una notifica non appena un comando lungo termina l'esecuzione. Nelle ultime righe alla fine del comando, vedi che tipo di errore sta affrontando il tuo sistema. Sì, vedrai sicuramente un errore.

Nel mio caso, ho visto il famoso errore GPG: il seguente errore non può essere verificato. Apparentemente c'è qualche problema con l'installazione di Spotify in Ubuntu 15.04.

È molto probabile che tu possa vedere un errore diverso invece dell'errore GPG come me. In tal caso, ti suggerisco di leggere questo articolo che ho scritto per correggere vari errori comuni di aggiornamento in Ubuntu.

Conosco poche persone, specialmente i principianti hanno una forte avversione per la linea di comando, ma se si utilizza Linux, semplicemente non si può evitare il terminale. Inoltre, non è quella cosa spaventosa. Fai un tentativo, ti sentirai abituato abbastanza presto.

Spero che questo suggerimento rapido ti abbia aiutato a sistemare le ricorrenti "informazioni aggiornate non aggiornate" in Ubuntu. Qualsiasi domanda o suggerimento è ben accetto.

Raccomandato

Come usare i file RAR in Ubuntu Linux
2019
Vedi la cronologia chat modificata di Skype in Linux
2019
No scherzo! Microsoft ha aderito alla Linux Foundation
2019