Come risolvere il problema: impossibile scaricare cdrom apt-get update non può essere utilizzato per aggiungere nuovi CD-ROM

In questi giorni sto sperimentando con Elementary OS Freya e durante questo, ho riscontrato un errore di aggiornamento molto comune: Impossibile recuperare cdrom Si prega di utilizzare apt-cdrom per rendere questo CD-ROM riconosciuto da APT. apt-get update non può essere utilizzato per aggiungere nuovi CD-ROM . L'errore completo è simile a questo dopo l'esecuzione del comando apt-get update:

W: Impossibile recuperare cdrom: // elementary OS 0.3 _Freya_ - Daily amd64 (20150208) / dists / trusty / main / binary-amd64 / Pacchetti Utilizzare apt-cdrom per rendere questo CD-ROM riconosciuto da APT. apt-get update non può essere utilizzato per aggiungere nuovi CD-ROM

W: Impossibile recuperare cdrom: // elementary OS 0.3 _Freya_ - Daily amd64 (20150208) / dists / trusty / restricted / binary-amd64 / Packages Utilizzare apt-cdrom per rendere questo CD-ROM riconosciuto da APT. apt-get update non può essere utilizzato per aggiungere nuovi CD-ROM

E: alcuni file di indice non sono riusciti a scaricare. Sono stati ignorati, o usati invece quelli vecchi.

In questo post vedremo come risolvere questo errore.

Correzione Impossibile recuperare cdrom apt-get update non può essere utilizzato per aggiungere nuovi errori di CD-ROM

Il motivo di questo errore è che cdrom è stato incluso come una delle fonti qui. E per risolvere questo problema, dobbiamo rimuoverlo dall'elenco delle fonti software.

In Ubuntu, cerca Software e aggiornamenti:

Nella prima scheda Software Ubuntu, cerca il cdrom, se è selezionato, deselezionalo.

Chiudere le fonti software ed eseguire di nuovo l'aggiornamento. Dovrebbe funzionare bene ora.

Ulteriore risoluzione dei problemi:

Il metodo descritto sopra dovrebbe aver corretto questo aggiornamento apt-get non può essere utilizzato per aggiungere un nuovo errore di CD-ROM . Ma non era questo il caso per me, perché l'opzione di cdrom era già in grigio mentre stavo usando la sessione live.

Ora per correggere il nostro errore, prenderemo il percorso della linea di comando. Apri un terminale e usa la seguente linea per vedere cosa è incluso nella lista delle fonti:

cat /etc/apt/sources.list 

L'output per me era il seguente:

deb cdrom: [elementare OS 0.3 _Freya_ - Daily amd64 (20150208)] / trust principale limitato

deb //archive.ubuntu.com/ubuntu/ trusty main universe universe multiverse

deb-src //archive.ubuntu.com/ubuntu/ trusty main universe universe multiverse

deb //security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse

deb-src //security.ubuntu.com/ubuntu/ trusty-security multiverse dell'universo limitato

deb //archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse

deb-src //archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse

Guarda la prima riga nell'elenco sopra. Include cdrom. Abbiamo bisogno di commentare questa riga aggiungendo # di fronte per farla apparire come questa:

#deb cdrom: [elementare OS 0.3 _Freya_ - Daily amd64 (20150208)] / trusted main restricted

Per farlo usa il comando qui sotto:

 sudo gedit /etc/apt/sources.list 

Una volta modificato il sources.list, eseguire nuovamente apt-get update. L'errore apt-get update non può essere utilizzato per aggiungere nuovi CD-ROM che avrebbero dovuto essere corretti. Se stai affrontando qualsiasi altro problema di aggiornamento, consulta questo articolo che è una raccolta delle più comuni correzioni di errori di aggiornamento di Ubuntu.

Spero tu abbia trovato utile questo tutorial. Se avete domande o suggerimenti, sentitevi liberi di lasciare un commento.

Raccomandato

CPod: un'app Podcast open source e multipiattaforma
2019
5 libri di Ubuntu gratuiti per principianti
2019
Come risolvere: No Unity, No Launcher, No Dash In Ubuntu Linux
2019