Risolto il problema "Impossibile scaricare le informazioni del repository" in Ubuntu

Questo articolo è stato originariamente scritto per Ubuntu ma è ugualmente in grado di risolvere il problema "Impossibile scaricare le informazioni sul repository" in Linux Mint e altre distribuzioni e versioni Linux basate su Ubuntu.

Recentemente, mi sono imbattuto in un problema di aggiornamento. Ho notato che per un paio di giorni, Ubuntu non mi aveva informato di nessun aggiornamento disponibile. Considerando che stavo usando la versione beta, mi sentivo molto strano non avere alcuna notifica di aggiornamento. Questo è il motivo per cui ho deciso di verificare eventuali aggiornamenti disponibili per conto mio. Ho eseguito il programma di aggiornamento del software e dopo aver controllato gli aggiornamenti ha generato questo errore:

Impossibile scaricare le informazioni del repository. Controlla la tua connessione Internet.

In questo tutorial, ti mostrerò come risolvere questo problema di aggiornamento in Ubuntu.

Come risolvere "Impossibile scaricare le informazioni del repository" Errore di aggiornamento:

Poiché non sono disponibili ulteriori informazioni nella GUI di Software Updater sulla causa dell'errore, dobbiamo utilizzare la riga di comando per scoprirlo.

Passaggio 1: scopri cosa sta causando l'errore

Apri il terminale (Ctrl + Alt + T) e usa il seguente comando:

sudo apt-get update 

Attendi che questo comando venga eseguito completamente. Dovresti mandarti un errore alla fine, qualcosa del genere:

 W: Failed to fetch //ppa.launchpad.net/venerix/pkg/ubuntu/dists/raring/main/binary-i386/Packages 404 Not Found E: Some index files failed to download. They have been ignored, or old ones used instead. 

Come puoi vedere sopra, il programma di aggiornamento non è riuscito a trovare un pacchetto PPA specifico. E questo era il motivo per cui Software Updater non è stato eseguito correttamente.

Passaggio 2: rimozione della causa principale del problema

Una volta che sappiamo che questo PPA (o qualsiasi altra fonte software) è la causa principale di questo errore di aggiornamento, il passo successivo è rimuoverli dall'elenco delle fonti software. Per farlo, apri Software e aggiornamenti da Unity Dash:

Nel software e aggiornamenti, vai su altro software e cerca l'origine del software che causa questo problema. Deseleziona la casella prima di escluderla dagli aggiornamenti futuri.

Questo è tutto. Non è necessario riavviare o qualcosa del genere. Basta eseguire di nuovo l'aggiornamento software e dovrebbe funzionare normalmente.

A proposito, questo passaggio escluderà semplicemente questa sorgente software dall'elenco. Per liberarsene completamente, leggi questo articolo su come eliminare un PPA.

Nel caso ti stia chiedendo perché questo errore sia avvenuto in primo luogo, è stato a causa di un PPA non supportato per la mia attuale versione di Ubuntu. Avevo aggiunto un PPA che non era disponibile per la mia versione di Ubuntu ed è per questo che l'URL specificato nell'aggiornamento ha dato errore 404.

Domande, suggerimenti, aiuto? Sentiti libero di cliccare sul riquadro dei commenti.

Raccomandato

Lancio di Ubuntu per i telefoni
2019
Cosa succede se gli utenti di Linux hanno fatto film!
2019
Risolvi il problema di montaggio della partizione di Windows in Ubuntu Dual Boot
2019